Audio Unit Processor - UI Display

Having mapped parameters direct on the Audio Unit Processor module in Drambo (whether mapped from list or direct from the AU UI) is brilliant. 

My observation is that when clicking into an AU it’s a bit hit and miss as to whether you can see the full display of the AU’s UI. In portrait or landscape mode. Some parameters are cut off or not visible.

You can eventually achieve full display in landscape mode (preferred). By re-entering the UI in portrait mode. Then coming straight back out (Pressing ‘X’). Rotating your device to landscape and reentering the AU. 

It would be an improvement to workflow if the UI was made to fit the available display in either portrait or landscape mode. And, that ‘fit to display’ was retained when rotating from portrait mode to landscape and back. Despite having mapped parameters direct on the Audio Unit Processor module, I still find the need to go back into the AU UI to make precise adjustments. 

Zoom and pan within the AU UI display would also be advantageous but not as critical. 

The issue described is particularly prevalent on devices with more limited screen real estate. Pics showing the issue are from iPhone X showing Gauss and Velvet Machine.

«1

Comments

  • recrec
    edited February 7

    It looks like it’s been fixed. Just tried these two in current beta and they scale fine here both on iPad and iPhone (6s+).

  • Great news, thanks @rec. Is that when rotating between portrait and landscape too?

  • Hmm... not quite :)

    After playing around with it a bit, there are still inconsistencies... f.e

    Gauss

    loads fine in landscape, but half UI is missing in portrait on load

    rotation to portrait works fine, rotation to landscape breaks UI

    Velvet Machine

    loads fine in both landscape and portrait

    rotation to portrait works fine, rotation to landscape breaks UI


    The good news is that I haven’t noticed ‘hit and miss’ behaviour, and going full screen and back always fixed the problem.

    @giku

  • Thanks for checking @rec I think any additional step breaks the creative flow and becomes frustrating over time. Hopefully another hour or so and this can be fixed 😊

  • Could I ask a question on this to the Beepstreet Dev team? 

    Feels like this sort of thing isn’t right for ‘FEATURE WISH-LIST’. Whilst not a bug, as such, it’s not expected behaviour (which I guess technically is a bug) 😊

    Whilst I’m sure there’s a big (daunting) list of ‘Wouldn’t it be good if Drambo could...’ things people have raised. I know I’ve contributed 😇. Is there a way of letting the community (and individual) know when an issue/observation like this has been picked up, assessed by the team and rejected, or accepted for future development and put on the roadmap?

  • recrec
    edited February 20

    In general, we’re trying to provide info where we can.

    This particular case is a good example why’s it difficult sometimes...

    support for all device sizes, rotation, some issues can be addressed in Drambo, others cannot. Finding all the hidden traps that came with AUv3 support will take time, and require ongoing effort.

    Reporting issues is a huge help in this, so please do make noise :)

    edit: I’m cheerleader team :)

  • I agree, on the whole a very good job is done by the entire team regarding this. I’ve certainly had quick and positive responses, even from the Head Honcho 😉

    It’s good getting some acknowledgment when something is raised. Even if it’s ‘We’ll look into it but it’s marked low priority’ (personally I think this one should be a higher priority as it affects AU3 workflow, kills the moment and the fix may not be too time consuming) 🙂

    It just lets you know it’s worth raising these things (as you’ve indicated it is) and, perhaps more importantly, lets the rest of the community know what’s being looked at.

  • Just sayin', this is pretty tough for a single developer. All the sort of discipline that comes from logging reports, prioritizing them, estimating effort, and executing, is hard to apply for a single person, especially with an app as complex as Drambo. Best to just relax and let it flow. And you can email specific bug reports to him directly; check the contact info. This forum is more about help, techniques, and discussion of possible new features.

  • I get that, I hadn’t looked into the company structure 🤣 For all I knew, Giku could have a team of people around him. Let’s not lose perspective here, it’s just a question, and a relaxed one at that. I don’t think anyone should be discouraged from asking questions, but thanks 👍

  • edited February 27

    Turns out this is not a Drambo fix. Giku kindly explained today that Drambo takes an AU window and embeds it, AU lays out its view, so it’s out of Giku’s control. Emails have been sent to Brambos (Gauss) and Yuri (Velvet Machine)

  • Can someone add GeoShred to that list please?

    I’ve been dying to use GeoShred in Drambo but it’s all squashed looking.


    I’ve tried the rotation tricks.

  • @giku In addition to those AU’s already mentioned, please be aware Atom Piano Roll 2 has similar issues.

    Appreciate the issue is exacerbated, in part, due to the lack of AU standards from Apple, but it would be great to get some focus/collaboration going to at least investigate the AU UI problems and see if there’s a possibility of a resolution.

    I hope this can get fixed. New features and modules etc are great but currently AU’s aren’t usable/performing as expected.

  • I'm gonna take a deeper look at this.

    Can't find whats wrong with Atom (testing on ipad 11'') so far.

  • Thanks @giku 🙏

    Screenshots in the link for iPhone X but let me know if you need anything else.

  • Confirmed,

    It initially displays right, then gets messed up after rotation. Tapping twice on fullscreen icon fixes this.

  • Doesn’t display right for me initially. You also completely lose the right hand side buttons for both the AU And Drambo rotating from portrait to landscape in full screen mode.

    I wonder if it’s the positioning of the X, Full Screen and Map buttons on that right hand side that’s causing the issues, and if that could be moved to the right of the Transport controls? 🤔

  • Fit full screen in landscape, see below (which you get to eventually with a lot of fiddling) is workable. Ideally you’d have a little more space with the right hand menu moved. Could really then just do with the ability to pitch zoom, in that view, to allow you to focus in briefly.

  • I can't handle gestures in AU window.. its not my area. :)

  • edited March 18

    Testing in AUM the Piano Roll section (not nav) does have pinch zoom. I can’t test it again in Drambo as this morning the AU won’t even load 😕 I’ll obviously go back to Victor with anything that’s purely his 👍


  • If you have a repeatable test case, pls send it to developer. (plugin crashed)

  • You mean email you the test case? 🤔

  • edited March 18

    Last bit of input for you for now. Using DRC as a simple comparison of AU experience. I’m sure you can see the issues. Unfortunately, at the stage, AU’s on iPhone X are unusable in Drambo 😕

  • @Connor Atom developer has Drambo, just tell him how to make it crash and he will catch this in debugger for sure.

    Thanks for the video... Just one question: does tapping on fullscreen icon (up/down arrows) fix it? (make it usable?)

  • Nope. If you watch the video I try tapping on the fullscreen icon. Still unusable. Same for at the AU’s I’ve mentioned.

  • Ok I’ll refer Victor here.

    1. Load fresh instance of Drambo
    2. Tap ‘+’
    3. Tap ‘MIDI’
    4. Tap ‘Audio Unit MIDI Processor’ presets (bullet point/hamburger icon next to ‘Audio Unit MIDI Processor’)
    5. Tap ‘on Atom Piano Roll 2’ AU
    6. Resulted in AU not loading and showing ‘Error’ in module
  • Ah ok.. its that simple! The problem is ... it works here (ipad pro, iphone XS). The other problem is I'm on ATOM beta (testflight) :) its possbile that he fixed this problem here.

  • I'm gonna contact the dev

  • Yep that simple 🤣

    I’ve sent Victor a PM on Audiobus. I’ve also mentioned the display stuff too (so you’re copied in) in the hope that you’ll collaborate and find a solution in keeping with the rest of both of your beautiful work 😊

  • edited March 18

    Yes we are in touch. The layout issue is here, to be fixed (working on this), but both of us can't repeat the crash issue on any device.

    I wonder whats special in your setup / config.

  • edited March 18

    Nothing special, iOS 14.4.1, iPhone X, 256 GB with c. 185 GB free.

    The crash issue worked as expected on my last test 🤷‍♂️

    Also spotted this one, if you follow the same test case steps (but with the audio unit working). Pinch zoom the piano roll once, then tap ‘X’ to close. Then delete the Audio Unit MIDI Processor module. The CPU meter shows as maxed out and stays that way.


Sign In or Register to comment.