Audio Unit Plugin Invalidated (AUM)

Fresh instance of AUM, loaded Drambo. Tried to open an existing project (to record a copy of a live performance) but kept getting this. Anyone experienced this before and found a solution?


  • Did you try a reboot?

  • This "disappearing AUv3" problem is experienced by some iOS 14 users. Actually, the host app is unable to enumerate any AUv3's, not just Drambo. As suggested by @Carnbyte , the fix is a reboot (power off). It lasts at least a couple of days.

  • What do you mean with not just drambo?

    i don’t get disappearing AUs in drambo

    but they disappear in Audiobus

  • edited February 19

    The iOS 14 bug I described causes all AUv3 to disappear in all hosts, as if there are none installed. I meant that Drambo is not the only AU that disappears; no reference to the Drambo host at all. If AU only disappear for you in Audiobus, that may be a different problem. They've never disappeared for me, although I lost the icons (only) a couple of times in AB, but that seems to be fixed (by AB) now.

    Are you losing the AUs completely, or just the icons (every unit gets a generic icon)?

  • edited February 19

    I guess it’s the icons thing in ab

    anyway, I just wanted to make sure you don’t have that in drambo.

  • edited February 19


    I solved it, basically stripped out every unused resource in each track in a standalone instance. Then reloaded in AUM as an AU3 and loaded the new version of the project. After turning it off and on again 😉

    Drambo hadn’t ‘disappeared’ as such @uncleDave, it loaded in as an AU3. The ‘BPST: Drambo Failed’ issue occurred when I tried to load my project inside the Drambo AU3 instance.

    The project wasn’t particularly complex so this wasn’t expected behaviour. I’ll just keep an eye on it.

    Thanks for coming back to me 🙂

  • edited February 19

    Remember u can’t open a Plugin in a Plugin ...

    it’s a restriction of iOS.

    but you can open drambo in drambo as long as these projects don’t have other AUs inside.

  • I was opening a Drambo Project, in a Drambo AU3 instance, in AUM? 🤔

  • edited February 19

    Did that drambo project have other AUs inside? Or are you only using drambo modules in that project?

    Can you repeat that?

  • edited February 19

    No it didn’t have any AU3’s in the Drambo Project, just Drambo modules.

    Interesting that you can’t open a project with AU3’s in, inside AUM. I didn’t know that, but of course it make sense not to be able to open an AU3 inside an AU3.

    Wasn’t that in this instance but thanks for coming back to me 😊

    Begs another question, what do people use to record a live performance of a Drambo Project? 🤔 I appreciate there’s the ‘Export Audio’ option but what about when recording a more fluid live performance?

  • edited February 19

    I just remembered someone mentioning simply adding the Flexi Sampler to the Master track*. Recording your performance, then just saving the (long) sample. Then you can move the file wherever you want to listen to it.

    * Just tested this and unfortunately you’re limited to c.30 seconds of recording time.

    Going to have to find another solution.

Sign In or Register to comment.