Crackle and pop. What am I doing wrong?

edited August 2021 in Known issues


For months I’ve being having this problem. Running Drambo in standalone. Nothing attached but my charger. No au’s except bark filter on master.

Drambo runs fine for a while and all of a sudden, cracks popping and crash. iPad becomes unresponsive for a while, and because I hit the play button, after a while recovers and continues fine again. Sometimes, rarely, the device decides to restart.

I’ve been trying to nail down what causes this, but it totally eludes me. WiFi on or off, airplane mode, hard restart with all other apps swiped up to close. Made projects just to stress test, unscientificly testing if its filters, or analog filters, or modulation, lfo’s, wavetable oscillator and many more possibilities. Can’t figure out what little devil is hiding and causing this problem for me.

Below a few screengrabs showing my issue. It’s from a deliberate test, so please disregard me noodling and the musicality. As you can see, the resource meter shows one bar. It still crashes. The last video is after I went to close all apps, switch to airplane mode, then hard restart with holding home and power, started Drambo, opened project.

I don’t mind too much for just sitting here on the couch and playing, I’m a happy camper. It just completely puzzles me 😝

Is my iPad dying? (iPad mini 5th gen, iOS 14.7). Is it the iOS version? User error? A module I’m not using correctly? Bad luck like this whole pandemic made it so we haven’t had any guests since March 2020? Could it be the charger? Rainy season? Is it my approach? Am I doing this wrong? I’m no wizard so actually I think my ‘patches’ are pretty simple. I’m lost haha

For testing, here’s a Dropbox link to the project. You just might need to delete the Bark filter on the master if you don’t have it.


  • edited August 2021

    What buffer size in settings?

    At the first dropout I can see the CPU meter turning red, at the second one it doesn't. A common scenario?

    Please also check the battery activity in iOS settings after running on battery power for a while.

    Which are the top other apps?

    Try force-closing all apps then reboot and run only Drambo again, set a higher audio buffer in Drambo settings and try again.

    I hope it's not iOS 14.7, recent iOS 14 versions have repeatedly caused various audio troubles.

  • Buffer settings as in the image. Sometimes red, sometimes not, that’s why I’m asking, I can usually fix stuff, figure it out by doing some searches, this totally eludes me. I’m usually connected to power.

    other top apps? I haven’t found any difference between having used the device for several days and starting Drambo, or first closing all apps (swiping up), then choose airplane mode, then a hard reset with home and power button.

    Im on 14.7. I unfortunately, upgraded from, erm 13.Something that was working fine. From memory, which is sketchy, no problems like this when I was on 13. It could really be that, but that would mean more people would have this problem right?

    thanks for your reply btw

  • The user and all related content has been deleted.
  • I'm working quite extensively with Drambo on iOS 12 and 13.7 and I have never experienced this issue yet.

    Neverending reports about audio issues with 14.x have kept me from updating to 14 for more than a year now.

    My only iDevice on iOS 14.7 is an old iPhone SE, gonna try this.

  • I’ve run it for a few minutes tweaking various parameters but here all runs ok. Pro 10.5 latest iOS.

  • edited August 2021
    The user and all related content has been deleted.
  • OK, I've played the factory project "Drambo on waves" several times on the SE, iOS 14.7.1.

    Audio buffer was set to 512 samples, WiFi on, Bluetooth off, used the internal speaker only.

    The CPU was consistently at 1 of 5 dots and no audio issues at all.

  • The user and all related content has been deleted.
  • @frank303 & @Gravitas

    How long did you play your projects until glitches would start to show?

  • The user and all related content has been deleted.
  • Typically it happens quite quick, after 5 or 10 minutes after starting. Then, it could take a whole while before it happens again, or like last night, happen very consistently. This behavior is quite regular, I play every night, for quite long times. I have a feeling it improves a tiny bit when in airplane mode, and doesn't happen as often on super light projects of only 2 or 3 tracks. I have projects it happens all the time, after 5 minutes, really every time, but that's with 12, or even 15 tracks. Still, the resource meter never goes above 4 out of the 5 dots.

  • I still cannot confirm it on the SE, maybe something was fixed in 14.7.1?

    Had that factory project playing for 14 minutes now. No dropouts, no crackles, super low CPU load at 512 samples buffer.

  • There have been reports of this crackling with iOS 14.5 and the newest Apple processors, A12, A14, and M1. Your iPad Mini 5 has the A12, so you could be affected. Turning off Mic access for Drambo might help. See

  • edited August 2021

    do you have other apps running?



    "Sometimes, rarely, the device decides to restart."

    this shouldn't happen at all; something is very wrong here

    device faulty?

  • edited August 2021

    No close all apps swiping up, and a hard reset starting in airplane mode doesn’t solve it. The restart is indeed strange. It happens when the device really hangs, completely stuck and unresponsive, then after a minute or so it restarts.

    I’d have peace, albeit be a bit depressed if I was sure it’s my iPad dying, because then I’d know for sure what’s wrong haha. So I don’t have to break my head trying to figure out if I load too many cv sequencers or filters. I live in the Philippines, basically at the beach, always outside so it’s not exactly hi tech friendly environment. Had two MacBook airs fry their logic boards, repairservice claiming it got wet, but I’m hundred percent sure there were no spills or anything. So the ocean air and rainy season humidity might now also be slowly killing the iPad.

    Perhaps I’ll do some checks with aum, don’t use it anymore but perhaps I can get a similar crash?

    Edit: just opened this project inside aum, same thing, after 2 minutes lots of crackles. Seems to recover a bit quicker. When it’s playing aum dsp is 35% and Drambo shows 2/3 dots. Then everything turns red, crackles, then recovers again.

  • The user and all related content has been deleted.
  • edited August 2021

    salty Air/ humidity and heat are poison for computers …

  • @frank303 If you want me to try your project on my iDevices, you can pm me your project.

  • The user and all related content has been deleted.
  • edited August 2021

    Here is a link to the project. I started it yesterday as a sort of test. I’m contemplating a setup with hardware, and don’t want to get an Octatrack or mpc as these machines won’t probably last too long in this climate and beach life. Too expensive to be written off after a year or two. 50 or 100 dollar midi controllers however I can live with them dying after a while. So have to do almost all with the iPad. Then I’d like to add a model d or similar cheap synths that I can afford to loose over time, and relieve the iPad a bit. Then, I need some workflow inside the iPad to support some live playing. Was looking at the Korg sq64 or beat step for sequencing, but alas, I’d like to try to have the iPad do the sequencing. Made a midi rack with plenty of cv and Euclidean sequencers, and stuck that on all tracks. Eventually to be controlled by midi. I then added some random instrument racks to see how Drambo would hold, and what the limit would be. So it’s nothing fancy at all.

    now the thing I’m wondering is why it crashes while showing so little resource usage? I have other projects, chuck full, and pushing the limit and then I’m not that surprised it hangs. But this one made me make the post, as it really crashes s all the time.

    I tried just having it run, and then it’s actually fine. It’s when I start it up, and just casually moving some envelopes and filters it crack, say 5 min in.

    I just tried switching all analog filters off hq, and deleting delays but same.

    Edit: I just noticed the iPad is getting a bit hot from playing this project for a while? I don’t believe it often gets hot actually? And I have been using Drambo A LOT over the last 8 months or so.

  • The user and all related content has been deleted.
  • Runs fine here... no issues after 5-10 minutes of tweaking, no warmup... don’t have bark filter though

    2dots on the cpu meter, never went higher, occasionally drops to 1

    air3 13.7

    to me it seems like audio engine issue (iOS 14.x with newer iPad models)

    does it happen if you remove everything AUv3?

  • Found 1 crash report from yesterday when the iPad restarted. Mailed it.

    Its only Bark and one instance of Continua, but the problem persists with or without, and also hosted in AUM.

    Thanks all for thinking along!

  • No probs running your project @frank303 on the old iPhone SE, on iOS 14.7.1, for 25 minutes.

    Like in rec's case, CPU load is at 2 dots.

  • The user and all related content has been deleted.
Sign In or Register to comment.