Zeeon Audio Unit fails to record triads - MIDI blocks in GarageBand - iOS 15 compatibility ‘damage’?

Here’s the message I was trying to send to BeepStreet - keep getting error 404 no matter how short I make it. It outlines the problem as well as I could…if anyone here knows how to contact them at Beepstreet great, please let me know? Thank you.


Zeeon has a spookily similar issue to Moog.


I sent a message, but there was an error 404…


Fri 29th October 2021


Hi JJ and whomsoever else at BeepStreet. Love your instruments. Using Zeeon now because on my iPadOS iPad Pro 2 12.9 inch, the Moogs (Model D and Model 15) have gone ‘wonky’. Their arpeggiation started to sound different on the recorded midi block, to what I was playing. Not WYSIWIG (er, WYPINWGR?! Pls pronounce it Wipin-Wigr). Anyway…I turned to Zeeon as one of the handful of ‘mainstays’ I have on iOS, and unfortunately, found it also has suddenly started to suffer the same issue.


I did a few tests, and narrowed the Moog down to it being that either an extra key was getting ‘stuck down’ invisibly when the MIDI block was put on record and appeared in GarageBand on my iPad Pro 2, or a key was the opposite - not being pressed. It made the arpeggiation go as I say ‘wonky’.


Your Zeeon seemed absolutely fine. Right up until tonight (Friday 29th - Halloween weekend of all things) when I just laid down a very short chord sequence of 3 notes (triad), then two note chord, then another 3 note chord, then a final 2 note chord. Nothing really at all. Now, I thought when I played it back in GB, ‘that sounds a bit thin’. Those triads were not the lush soft pad sound they should be.


On inspection ( I took screenshots), looking at the MIDI block in green on the GB track Zeeon is on, it is mysteriously devoid of my triads! Only TWO NOTES were recorded in parallel each time. The actual 2-note ‘chords’ came out fine.


HOWEVER when I went into ‘edit’ moded, the track balloons up as normal, that kind of zoom-in thing, then the three-note triads mysteriously reappeared in MIDI line form - but crucially, the full complement of 3 notes do NOT sound off. One is left out, even though it is clearly visible on the screen, but only in ‘edit’ mode.


Perplexing, is the word. Has never happened before, and I have had iOS/iPadOS 14.8 for a while. I just upgraded to 14.8.1 and am using the latest version of GB in the iPad Pro 2 12.9 inch. It’s got 75Gb free SSD out of 512Gb, and I am on the cloud because I don’t want that space to diminish as fast as it would if I stored stuff on the ipad itself, directly.


Following my IT experience that you look for the change that happened around the time of the issues beginning, this reeks of the move by developers to make their Audio Units compatible with iOS 15. Of course, I won’t move to iOS 15 for about a year at least - heck I missed out iOS 8 entirely! I just didn’t update for a year, it was a stinker.


So, that’s as much as I can narrow it down. It seems something to do with your devs’ hard work making the AUs iOS-15 compatible, has caused a weird glitch, and if it happens to MOOG and to BeepStreet, that’s ominous. Because you are both really, really good at what you do.


It’s not life or death, but I literally cannot play anything and be sure it will be the same once MIDI-recorded. In fact, it definitely is NOT going to be the same. With the Moog, there was another weird glitch, but I strangely managed to cure that, by deleting that particular track/Moog instance, and simply adding a Model 15 in afresh to a new track. The delinquent Moog, seemed to be alone in doing other ‘wonky’ stuff. Odd really - digital stuff is very repeatable usually.


I hope you can fix it - now I have to try ‘synthmaster’ which is another mainstay, and see if that will work. I have a feeling it won’t, if they’ve made it iOS-15 compatible. We’ll see. I hate doing IT experiments, I was very happy these past few days doing music problems!


Take care, keep well. You will resolve it I am sure.


My best

Ian R Margetts aka Richard Getts on itunes etc (‘Hot Woman Cool T-bird’ and others).

Comments

  • Hi and welcome to the forum Ian!

    First of all, Zeeon hasn't been updated recently and in my own projects, I've never had this happen.

    From what you describe, I wonder if it's rather something with Garageband - can you please try a different DAW?

  • Thanks for replying…yes, I just looked at Beepstreet’s info on Zeeon versions, and that’s right, not recently updated. There’d been a flurry of apps made ios 15 compatible.

    I will try Cubasis, and get back.

  • Well, I went and did the necessary identical tests on Cubasis, for Zeeon and the other two that had issues for me in GarageBand, the midi tracks not recording properly, although the played notes were fine, on replay from the midi track, triads were intermittently missing notes.

    Got it to a method: depress all three triad keys say from up at C4, then release the highest key, but hold the lower two a bit longer, then release the remaining higher pitch, and the idea is you can distinguish easily if the sound is ‘correct’ or not. ie that all three notes were actually sounding.

    The method works. Unfortunately, it just proved that my favourite DAW, GarageBand on iPadOS, doesn’t. GB is intermittently dropping notes, either from emitting, or from midi recording (as presented in the normal track view anyway), or both. In ‘edit’ mode, you might SEE all three notes are present for a chord, but only two of them emit sound!

    The reason I didn’t do this Cubasis comparison myself unprompted, was I thought it preposterous that Apple who conceived of the audiounit system, would not implement it the best of all the iOS DAWs. There you go, I can’t believe it really. I love GB, this is a downer. I will get around to prodding Apple forums I suppose.

    But, thanks for your help, I will contact the two developers I can, to say it seems most likely Apple’s baby DAW is at fault, as Cubasis 3 didn’t drop a note or stick a key with Zeeon, Model 15, or SynthMaster One. Live and learn.


    Take care, be well everyone!

  • Thanks for double checking!

    One more thing: Are you using the on-screen keyboard for recording?

    If so, do you have iOS multitasking gestures enabled?

  • Actually, I tend to leave it set so the on-screen is set to some basic ‘arp’ situation, and my little irig keys 37 keyboard/midi controller is for ‘normal’ playing of notes. So when i try out different sounds, i can quickly grasp if they have a talent for arpeggiating, or not? of late, anyway.


    iOS multitasking: no, you mean to do ‘accessibility’ type stuff like magnifying the screen, right? No, turned that off for this exact sort of reason I think.


    I contacted Moog and KV331 to advise my latest test results based on your prompting btw. It’s a bit cruddy to leave them with the impression I am saying they might have a mod to do, when I have almost definitely narrowed it down, they don’t.


    my best.

    irm/rg

  • edited October 31

    iOS multitasking: no, you mean to do ‘accessibility’ type stuff like magnifying the screen, right? No, turned that off for this exact sort of reason I think.


    Not accessibility: Settings > Home Screen > Multitasking > Gestures

    This setting defaults to on, and sometimes resets itself on iOS upgrades I think.

  • Thanks number 37…so I followed your possibility to the letter, and rebooted the ipad…no difference.

    Time to look at the more remote possibilities. It seems as if it is something borderline, that afflicts GB but not Cubasis, almost as if voltages or something put out by the irig 37 were not quite definite, and Cub3 is just a little less susceptible.

    Heck, it’s an excuse to dig out my 66-key controller keyboard, let’s be honest!

    I will persist, i would hate to be stuck with Cub3, brilliant though it is. It’s more finicky somehow, to me. But it’s awfully good, and doesn’t re-edit my recordings on the fly for me.

    my best

    irm/rg

  • Update: now used my Novation Launchkey 61 MIDI controller keyboard instead of irig keys 37, AND changed over to the non-powered pukka Apple USB single adapter to lightning - EXACT SAME MISSING-OUT OF MIDI NOTES occurred with same synth AND Apple’s own piano instrument.

    So the keyboard, usb to lightning adapter, power supply introduced for the novation, and a USB to printer-end cable replaces my irig 37 setup, and the exact same mis-recording/playback of midi notes in garageband iOS happens.

    Ergo, it’s GB iOS causing the issues. Oh, i freed up ssd space too, so it’s up to maybe 75gb free, so that’s not it. Does it with one or two instruments in a GB song, so that’s not it.

    Interaction between iOS 14.8 onwards and GB? It’s only been noticeable for a few weeks?

    Anyway, if anyone out there cares to try it and say if they find differently or the same?

    best

    irm/rg

  • Forgot you could put pics, here’s proof both keyboard controllers exist!

    best

    irm/rg


  • Provisionally, the issue has possibly been resolved, entirely. Not fully explained, but the fix is brain-numbingly stupid!

    So in-between all the testing and messing-around swapping out my little midi keyboard for the Novation 61-key behemoth, I was backing stuff off my ipad pro because iCloud has times it demonstrates an appetite for MY ssd storage (long story). The fix is nit quick and I need to backup to some SD32gb cards. So, USB powered hub etc gets involved.

    Relevance? Well it involves a lot of plugging and unplugging of the lightning connectors.

    I went back to GarageBand having quite enjoyed midi-mapping the Launchkey 61 controller in Cubasis 3 (GB iOS has no such user-alterable feature), and just tried some triad chords out just to prove to myself the issue still existed. No, it had gone!

    I tested some more, did an arpeggiation two-handed, nope, definitely no dropped MIDI notes, and on playback the track sounded fine now, as when played. Annoying, I thought. Did I imagine it? Went back to a vid I made, no, midi notes got dropped. 3 notes visible in GB ‘edit’ mode, but only 2 sound off when replaying.

    The last possible thing, I thought, was I now have a dirty great 12V ‘brick’ driving the USB hub, and thence the monster Novation keyboard. That’s a healthy bigger power feed than my little irig keys 37 gets, max 100mA from the ipad only.

    So, I checked the connectors, the lightning ends - see pic. I had not deliberately wiped them, but both had sooty deposits almost, on that tiny connector, both sides. See pic. Here then, is the only thing that makes sense, if it is resolved, this ‘dropping midi notes’ issue: a dirty lightning connector/socket, that is borderline corrupting the incoming MIDI signals.

    Without the need for a big Anker USB ‘brick’ power supply, and extra feed, the little irig 37-key controller, couldn’t pitch enough of a signal to be utterly clear to GarageBand what it was sending. GB has interpreted occasionally, one of the notes of a triad chord, to be a non-important or non-implemented command/midi signal. IE that third note ‘disappears’ in effect when recorded BUT when actually playing, I guess the routing must be, to play first, then drop a copy onto the MIDI track.

    Hence, playing while recording the keyboard, all is fine. Playback, you find the fault.

    I will run with this theory. I thank you so much anyone who pitched in, elimination of possible points helped me get here.

    In other words, I have wiped the lightning ends of the connectors (piece of ordinary paper folded over, old IT method), and will now peer into and carefully clean lightning socket of ipad with toothpick n tissue/air squirt can, etc.

    To say it was a cable connection issue all along, that was weird. But, I have my beloved GarageBand back (I think), and hey, got my big keyboard to play with now. Maddening though, innit.

    So long, keep safe, be well, and thanks.

    irm/rg

  • forgot the pic…


Sign In or Register to comment.