Version 2, physical iPad keyboard doesn't work in Search

edited May 20 in Known issues

Steps to reproduce:


  1. Add a module, bringing up the Library dialog
  2. Select Search textbox with trackpad or finger
  3. Hammer away on iPad physical keyboard
  4. Note nothing happens.
  5. Angrily disconnect physical keyboard and use onscreen keys instead.
  6. Calm down, send message to forum.


Tried disconnecting keyboard and reattaching. It does work in other dialogs (eg setting parameter values, setting file names etc.).

Comments

  • I think this might have something to do with the fact that Drambo supports qwerty-MIDI input - which I love, by the way!

    I agree with your frustration, but if this turns out to be the cost of allowing me to play notes and melodies from my qwerty-keyboard ipad case while I am away from my desk... then I would happily forfeit the ability to type into the search bar, and angrily disable bluetooth temporarily to type via the on-screen keyboard 😬.

    Note - the same problem occurs when trying to type into Drambo's Text module, though I've found a workaround by typing into an overlaid note app and copy/pasting the text into the text module via touch commands (long-press -> paste)

    Perhaps Giku can find a clever way to temporarily disable qwerty MIDI when any of Drambo's text boxes are in focus?

  • Thanks for the explanation tk32. I'd definitely encourage Giku to provide at least an option so both of us can avoid angry disablements 😀

  • edited May 20

    My Bluetooth keyboard has a function key combo to bring up the onscreen keyboard without disconnecting. It's used for entering emojis, etc. Is there maybe something like that on yours @ratbag?

    There's also a small floating toolbar at the bottom of the screen with a button at the bottom left that brings up a menu with a Show Keyboard icon.

  • edited May 20

    Oh you beauty @number37 - I never use those function buttons.. but it turns out I also have an on-screen keyboard toggle button on the row above my number 5 key.

    Thanks

  • @number37 thanks for that suggestion. Using an Apple Magic Keyboard I can't see a physical shortcut in the docs, but the "small floating toolbar" will ensure that I don't spend too much time disconnecting/reconnecting. Much appreciated.

  • I guess cheap Bluetooth key keyboards are more fully featured than Apple’s. 😉

    It seems as though long press on the toolbar button saves having to follow with a second menu pick.

  • so informative thanks

  • Latest patch (2.01) fixes this issue. Finally the mighty Magic Keyboard can achieve its full destiny and I can stop pressing fiddly icons to get a screen keyboard. Thanks @giku, appreciate your responsiveness to this kind of minor but annoying issue

Sign In or Register to comment.