drambo on macOS: howto?

Hi,

I've just bought Drambo, and wanted to make it run on my M1 MacBook Pro, but when I launch it e.g. from the App Store app or from the Applications folder, nothing shows up.

Is it supposed to run in standalone mode? Did I miss something? Is there anything special to do?

Sorry if it's obvious, but I could not find much info on that matter...

Best,

Stéphane


Console.app says:

par défaut   11:31:10.845263+0200   runningboardd   Launch request for app<com.giku.Drambo(502)> is using uid 502 (divined from auid 502 euid 502)

par défaut   11:31:10.845403+0200   runningboardd   Acquiring assertion targeting app<com.giku.Drambo(502)> from originator [daemon<com.apple.Dock.agent(502)>:9026] with description <RBSAssertionDescriptor| "LS launch com.giku.Drambo" ID:593-9026-291971 target:app<com.giku.Drambo(502)> attributes:[

   <RBSDomainAttribute| domain:"com.apple.launchservicesd" name:"LaunchRoleUserInteractive" sourceEnvironment:"(null)">

   ]>

par défaut   11:31:10.845530+0200   runningboardd   Assertion 593-9026-291971 (target:app<com.giku.Drambo(502)>) will be created as active

par défaut   11:31:10.845817+0200   runningboardd   Executing launch request for app<com.giku.Drambo(502)> (LS launch com.giku.Drambo)

par défaut   11:31:10.846064+0200   runningboardd   Creating and launching job for: app<com.giku.Drambo(502)>

par défaut   11:31:10.846297+0200   runningboardd   _mutateContextIfNeeded called for com.giku.Drambo

par défaut   11:31:10.879235+0200   kernel   App Store Fast Path -> /private/var/folders/_y/mk1ljg908xj95w0059blfnxr0000gp/X/DA7023B0-1F6B-5248-9512-38CD71E8B308/d/Wrapper/Drambo.app/Drambo

par défaut   11:31:10.879549+0200   kernel   proc 84546: set_code_unprotect() error 10 for file "Drambo"

erreur   11:31:10.880867+0200   Dock   LAUNCH: RBSLaunchRequest FAILURE <private> com.giku.Drambo <private> 0x0-0x1265264 failed with error Error Domain=RBSRequestErrorDomain Code=5 "Launch failed." UserInfo={NSLocalizedFailureReason=Launch failed., NSUnderlyingError=0x600003e344b0 {Error Domain=NSPOSIXErrorDomain Code=80 "Authentication error" UserInfo={NSLocalizedDescription=Launchd job spawn failed}}}

Comments

  • Salut Stéphane,

    are you running Drambo under the same user ID that you have installed it with?

    And which MacOS version are you on?

  • edited June 4

    Did you try to right click (2 finger touch) app icon — open? (Force Open)

    it’s supposed to be running standalone and as AUv3 plugin (in apps that support that)

  • thanks @rs2000 , yes I have the same ID. Otherwise, would I be able to just install it?

    I run macOS 12.4 (21F79).

    @lala tried it, to no avail...

  • I recommend checking SIP.

    If SIP is set to Permissive then in some situations apps will fail to launch and there will be no visual error message other than cryptic console logs. SIP needs to be on Full or Reduced.

  • edited August 27

    I can not replicate this with latest official released macOS and iOS. 🤷🏻‍♂️

    works here. :)

    I recommend update Mac OS to latest version. (12.5.1), delete drambo, and try again.

    Sorry for the inconvenience.

  • I was puzzling over this, also bc I had 2 Apple IDs, just got Drambo & Apple M2 macbook.

    Turned on Family sharing & linked my IDs, installed Drambo thru App Store. Done.

    Only iOS app I've installed. Notice that not all apps are available -- not seeing my AUV3's.

  • yes the mac and the iPad need to be on the same Apple ID the app was bought on

    that's how apple makes sure its still you

  • Just wish there were audio output settings for Drambo on Mac! Would love to pipe different tracks through Blackhole to route them to Bitwig for individual recording.

  • This. Loopback isn't enough. It's just stereo out, but selecting interface would allow usage with something like Existential Audio Blackhole.

  • edited September 1

    yeah, I’m currently using loopback to pipe Drambo to Bitwig, but like @auxmux mentioned, Drambo only enables it’s stereo master output. Would be slick if the ‘audio output’ module recognized Mac audio devices, like my interface, loopback, blackhole, etc. Just having an ‘audio output’ option in the settings menu itself would be an enhancement.

  • I finally found out why Drambo would not launch: it's related to macOS System Integrity Protection (SIP).

    Turns out I disabled it for my dev needs, and this would prevent Drambo from launching (as per https://www.reddit.com/r/MacOS/comments/qfrfzf/cant_launch_any_ipados_apps_on_my_m1_machine/)

    Turning it back on makes Drambo launch flawlessly... Don't know why Drambo is pickier than Model D...

  • something changed with network trallala during the last Mac OSes

    iirc you need to be an apple approved developer now to do certain things?

    I guess that's why it works when SIP is on (and you didn't mess with the system)

Sign In or Register to comment.