External MIDI stops working over time when used with fireface UCX

I have an RME Fireface UCX and am interested in using drama for liveset use as an octatrack replacement but right now MIDI on external gear just stops working after 10-30 mins. Audio inputs keep working but the MIDI light that indicates outbound messages stops blinking despite the sequencer still being active on the app. When the fault occurs the RME TotalFX app shows that the sound card is "disconnected" despite audio still working.

The only way I can then get MIDI working again is to quit Drambo and RME TotalFX, restart TotalFX and then Drambo. Then it works again for another half hour.

I'm using the last pre-M1 12.9" iPad with iOS 15.7.2. Unwilling to go straight to iOS 16 in case this causes fresh problems. Could use some help cos right now I'm 2k down on equipment costs and nothing works right.


  • What sort of MIDI messages are you sending through the interface, in both directions?

    What external hardware is connected to the MIDI interface? Does that hardware send MIDI Active Sensing messages? If it does not, your interface may be dropping the connection.

  • Just note on / note off. Only sending in one direction. The interface works fine in normal (i.e. not class compliant mode) in this use case scenario sending MIDI straight to my Disting EX in my modular when used with Ableton Live. The problem only occurs when I put the sound card into class compliant mode and use with iPad and Drambo.

    Some people at the RME forum are advising to upgrade to iOS 16. Has this been good for other people or is there experience of new headaches?

  • Could you try doing this without including Total FX? Just as an experiment to see if the MIDI works differently.

    Also, is there something in your modular rig that could send Active Sense messages to the MIDI input side of your interface? That would be worth trying.

    Users on the Audiobus Forum, including myself, seem satisfied with iPadOS 16.2. Some older apps may have problems, but not apps with current updates. The word of other RME users may be most important for you.

  • Starting RME TotalFX prior to Drambo seems to be a necessary step for Drambo to recognise all 18 inputs and outputs (otherwise I get stuck with 18 inputs and 2 outputs). It then just sits in the background.

    I’ll see if I can get something to send active sense back but it seems weird that the MIDI going down would make TotalFX report the sound card as disconnected, despite it continuing to serve and receive audio from Drambo.

    I’ve backed up the iPad and am installing 16.2 to see what that does.

  • You could try connecting the Disting EX MIDI Out port to the RME input. A MIDI monitor will quickly show if it's sending Active Sense. If it does, then connecting it may help keep the link active.

  • I'll try that, is this active sense issue known with other soundcards? Seems strange that it would occur in class compliant mode but not in regular mode when I use it with Live on the laptop where I can merrily send MIDI to the Disting for hours without using the midi input as an active sense return.

    Tried the 16.2 update, no dice.

  • Same bug occurs with midi back from Disting turned on. I’m starting to think this is Drambo specific because if I open up another MIDI app like Cubase or midi wrench I can send midi and receive audio fine. Quite frustrated with this, really want to use Drambo but can’t be done with having to restart it every 20 minutes.

  • Class Compliant mode would be running different firmware. And it could be very different, as in different authors, different years, etc. So it working differently would not be a surprise

  • Does Drambo actually stop sending MIDI? You could check with a monitor when it hangs.

    Are you connecting Drambo to the MIDI output in the exact same way as other apps that don't hang? Are you connecting to an actual port published by the interface, or is the TotalFX app involved somehow?

  • TotalFX is not involved, it’s just RME’s app for configuring the soundcard. Drambo stops sending MIDI to the port published by the interface.

    I seemingly solved the problem by backing up all my sets, presets and samples, deleting the app and re-installing it. MIDI then seemed to work all night. I guess rolling over the top updates are not all they're cracked up to be.

Sign In or Register to comment.