Moog Model D not accepting program change messages?

First off - what a refreshing new amazing app DRAMBO is! I stepped out of the IOS music making world for a minute and boom - the holy grail of live music sequencing!

So far I’m having great success using the midi PC generator to send program change messages to AU synths which accept them. Zeeon, Ruismaker - even external hardware synths - are successfully changing presets with PC msgs.

Supposedly Moog Model D also supports midi PC messages, but so far I’m not able to get it to work. Looked through manual and net searches, and nothing. I thought maybe Model D needs its PC msgs to be sent to a specific midi channel, but I tried them all.

What could I be doing wrong, or can anyone confirm that this is an issue with the Model D?



  • I've tested the Model D app with AUM and a StreamByter script that sends PC messages. It works fine when Model D is running as IAA (need to start Model D first, then connect AUM to it). The preset indicated in Model D changes, and the sound changes accordingly.

    But, when Model D is loaded as AUv3 in AUM, sending a PC message to it just seems to mute the output, maybe selects a non-existent preset. The indicated preset does not change. I had to reselect a preset using the Model D menu to bring it back to life. So it appears that the Model D AUv3 does not handle PC correctly. I tried inserting a Bank Select before the PC, but that did not help.

  • Thanks uncleDave. Good to have another user confirm. By the way, Model 15 does not have this issue!

  • Model D was just updated, maybe it has some under the hood fixes?

  • edited November 2022

    I don't think so. My test was with the latest version, 1.3.15.

    Ah, new version 1.3.16 today. Tested, no change in PC response.

Sign In or Register to comment.