OT - Wavetable, Audacity, sample rate - help!

Friends, I'm not having a good time trying to render single cycles in Audacity. I know this isn't Drambo specific, but there are a lot of great minds here I have faith in. I'm using the adventure kid research page for wave cycles at various sample lengths, but my renders always slightly exceed 1 cycle.

Here is the table with relevant numbers:

When I enter these settings in audacity however, it always looks like this:

I'm stumped about where I'm going wrong.. please help! 🙏

(this is why I wish Drambo could export frames from the WT Osc)

Comments

  • edited January 10

    lets try something else,

    open a single cycle that fits,

    zoom in, draw ish

    export

    open file again

    ?


    have u tried with 44.1?

  • When I try the calculation with 44.1khz, I get a perfect cycle. It's so strange.

    256 x (1/44100) =0.00580498866 (5.8ms). This is about 172.265hz.

    When I enter these numbers, I get a perfect cycle. But the math is messier, 48khz is neater. I just wonder why I can't render perfect cycles with 48khz. Maybe there's some hidden setting in Audacity somewhere..

  • edited January 10

    your tracks in audacity and the projectsamplerate can be different things,

    maybe its that?


    since the cycle is to short, its to high in pitch or wrong samplerate trallala

  • edited January 10

    Ugh, I'm an idiot. It was the default sample rate. I thought that this was a track specific setting, but it was more of a 'global' setting in preferences.

    Well.. problem solved! Now onto wavetable creation!

    yep, that was it! Thanks for helping me work through it!

  • @aleyas FYI, the WT frame size in Drambo is 2048 samples, not 256.

Sign In or Register to comment.