Auto-grow only works for active track?

Not sure if it is a bug or by design. I tried Piano Motifs to Drambo midi feedback output, recording PM's 3 midi channels to the 3 following tracks in Drambo. Noticed that auto-grow only grows the track you happen to have selected, not all 3 tracks with incoming midi.


  • Yes. The workaround involves turning the auto select track in settings. This will make the incoming note on any track switch to that track. Not recommend when notes come in at different tracks simultaneously as the screen will go crazy.

  • Ok. Will hopefully get fixed one day. Another workaround is to make all clips excessively long before recording, then trim.

  • NB this is not a bug so it cannot be fixed 😉

    Does Drambo receive midi on more than one track simultaneously?

  • Yes, when you set the tracks to Receive: Always.

  • I have each track receiving on separate channels all set to always. However I record tracks one at a time so autogrow with auto select works perfectly for me. In fact I often use it to switch between tracks via a controller.

  • This is my #1 frustration with Drambo at the moment. I feel like the addition of a ‘record arm’ button could mitigate the issue. But I suppose this conflicts with the design philosophy of immediacy of recording.

    it’s also a real headache to record track generated midi back onto the sequencer with MIDI Feedback, because as soon as you change track views to adjust some parameters, auto grow disables, and OVERDUB begins, ruining whatever had come before it.

  • I can see there is a UI challenge with auto growing all tracks; only the active track has a highlighted clip, knowing what to grow.

    One potential solution would be to have two settings:

    • Auto-grow active: same as today
    • Auto-grow all: auto-grow all clips that are on the same row as the highlighted active clip
  • edited February 10

    Or there could be a small hierarchy of ‘REC Arm’ levels. Tap ‘rec arm’ icon once, it lights up red, and it records the current clip length. Tap ‘rec arm’ icon again, it lights up orange, and it will auto grow the clip.

    usually I only want to multitrack record a few tracks, such as if I’m recording an electronic drum set live, or if I’m playing two controllers. In other instances, I want to bounce rack midi onto the timeline sequencer. In other cases, I have an AUv3 or VST (from desktop) with multichannel outputs, and I want to record them for an unspecified length of time. All are rather common scenarios, but such a headache with Drambo’s auto grow.

    Record arming tracks is daw and multitrack recorder 101. I think it’s the path of least resistance forward to fix these issues with multitrack midi recording.

  • edited February 10

    @aleyas Not sure if it's a good idea to re-purpose the second tap on REC for autogrow instead of disabling REC. I do prefer long tap (tap hold) for such auxiliary functions, in this case opening a little menu to potentially show a few more options.

    Now @giku will say that REC acts immediately so any of these auxiliary functions would destroy that, and he'd have a good point 😉

  • Ah, I wasn’t clear in my description. For the multiple taps I mentioned, that would just be for a proposed ‘rec arm’ icon on each track. The global rec button’s functions shouldn’t be changed, I agree. The immediacy makes song writing great.

    I just wonder what could be a potential solution for multitrack midi recording, with auto grow.

  • I’m easy with any potential solution as song as it doesn’t rob me of my current workflow that suits me very well.

    @aleyas I know that originally @giku had Drambo set up as a drum machine with track for each drum sound but since then, with layer modules etc it’s easy enough to just put all of them on one track, or wouldn’t this work in your case?

Sign In or Register to comment.