Bitmask phase fx unreachable through MIDI feedback

The new Bitmask fx seems not to be reachable by an internal CC assignment, going out of the CC generator and controlling the wave FX types, If assigned to an external controller then it's reachable, the internal CC feedback is also fully scaled 0-127 so it's not missing any value increments, assuming it's a bug?


  • edited October 9

    This seems to behave the same for me in other list-type params (filter type, oscillator type); the last item is unreachable with MIDI CC feedback. I put away my external controller with knobs so I can't test if that works.

    Edit: I tried changing the CC generator input from a slider to a number module; by sliding past 1.0 I sometimes do get the last element, but it's inconsistent

  • edited October 9

    Indeed, the least inconsistent way so far is to have a knob and a number 1.100 both going to N-1, knob controlling the position and N-1 set to X-Fade, almost lands every time on last parameter

  • Would using a morph module mapped to the list help?

  • The morph knob itself does the right thing, but MIDI-mapping the morph knob has the same problem, if that matters to @Moa13. It looks like the root cause is that the range 0.0-1.0 is divided like this for a list of 8 items (I checked with the mini oscillator types), so the last item ends up with a single value as opposed to a range:

    • Item 1: 0–1/7
    • Item 2: 1/7–2/7
    • Item 3: 2/7–3/7
    • Item 4: 3/7–4/7
    • Item 5: 4/7–5/7
    • Item 6: 5/7–6/7
    • Item 7: 6/7–7/7
    • Item 8: 7/7
  • Im curious why you would use midi CC feedback when you could use a morph or a knob directly.

  • edited October 10

    thanks for those @NoiseFloored, how does one map a morph to a list of items? doesn't seem to do anything here, besides detecting the target upon assignment

  • edited October 10

    @Moa13 You morph through a list of items by selecting the first item and assigning morph to the last one you want.

    Put a Morph module in front of the WT Oscillator with a Wave Effect module.

    Set the Wave Effect type to None.

    On the Morph module, hit ASSIGN.

    On the Wave Effect module, choose the last FX type in the list: Bitmask phase.

    Tap ASSIGN again to end the assignment procedure.

    Turn the Morph knob to the max and voila: The Bitmask phase effect is enabled.

    Regarding MIDI CC, you're right, the new Bitmask phase effect needs to be included in the family of effect types 😉

  • ah yes I see, I went exactly through your steps @rs2000 it's updating the waveforms with the morph now but not the names, it's constantly showing 'None' is there any reason for that?

  • Confirmed the label doesn’t reflect the position. Haven’t tried other list modules but I suspect this is just something Giku hasn’t had a chance to implement yet. Not a bug, more of a missing feature

  • Agreed. By the way, I was only pointing out the fact about the value ranges above in case it was an indication of a possible implementation issue; I'm not saying it actually is.

  • OK, @giku just confirmed that the text combo boxes will be updated to always show the current value.

Sign In or Register to comment.