How to get Drambo to acknowledge my synth as hardware controller

So my Roland S-1 works perfectly with Roland Zenbeats. (Transport is controlled by the play button on my synth, it also responds to tempo changes even live,

Drambo doesn’t seem to acknowledge the MIDI buttons or knobs. I tried by mapping midi learn and it didnt work. I also tried with a few knobs and stuff and also isn’t work

does Drambo need to like “add it to.a list of compatible devices” or should it work with just some settings adjustment?

have control, track and clock set to the S-1 midi out.


  • What kind of MIDI messages does the S-1 send?

    Drambo supports a good choice of MIDI controllers so it might be that the S-1 does some weird proprietary communication.

  • It sends standard MIDI and a proprietary one; you are right about that (AIRA link) But I disabled the AIRA. Idk, maybe because it’s really new (I think they are only a few months out )?

  • Download Hexler's "Protokol" app and post a screenshot of all the messages you see when tweaking knobs on the S-1.

  • edited October 2023

    @rs2000 , and then i just did some more

  • Excellent!

    I see 3 different controls (from pushing a button and turning 2 different knobs mabe?) and MIDI Status Start and Stop messages. Interestingly, I can see no MIDI Clock messages. Have you disabled them in Protokol?

  • edited October 2023

    No i didnt change anything on startup. Should i retry it? (Yes 2 different knobs ;) )

    EDIT - checked the manual, and set the clock to the units internal clock (not incoming./input midi clock from the iPad)

    didnt change the transport play though

  • edited October 2023

    Ok so I turned on the internal midi clock, set the Sync to MIDI clock, put the control, track and clock settings to the S-1 And it now works with the transport. Sometimes I have to turn off the S-1 in order for Drambo to recognize it apparently. I didn’t realize it, but it also is responding to knob maps too If i needed to map anything like parameters. Thanks @rs2000 if you didnt catch the midi clock I wouldn’t have been able to figure it out.

    @gravitas i also got the CC generator working, and now I can record parameter automations and stuff for the s-1….your instructions were super clear. Thanks man

  • Glad I could help 😇

  • No worries. 😇

Sign In or Register to comment.