Unable to record clean loops from patterns with flexi sampler

Hi folks,

When I try to record a perfectly looping pattern, recording it using the sync/clip option always produces some audible ms of silence at the start of the recording. Here's a screenshot with the waveform zoomed in:

In this example I've recorded a pad pattern from track 8 on the master, the pattern loops flawlessly when played back on the track. The silcence can't be trimmed because it would throw off the timing of the track.

Recording it using treshold doesn't produce this gap of silence, but it can't be used for timed recordings. A combination of both, clip & treshold would be nice.

Is this a known issue? I've recently upgraded my setup to a new iPad and iPadOS version and experienced the same on the older one, where all my recordings or exports got butchered in similar ways.

When you record something in Drambo using functions like sync/clip in flexi sampler or export a pattern, how does your waveforms look like when zoomed in?

Overall I'm really enjoying the app. Do you know a plugin that can be used in place of flexi sampler that can record clean loops until this may get fixed in a future update? (Koala can't automatically).



  • I've just tried to reproduce this by recording from a track in beat sync and even with maximum zoom-in, I cannot confirm it. I can see no delay here.

  • Spend some more time with it and found that without Chordjam in front of the chain I want to record I don't get the delay. Bummer because I really need that plugin, it's essential. It might happen with similar plugins too.

  • I have the same issue

  • What sample-rate is being used?

    All of Audiomodern AUv3's I've tried so far have timing issues when running at 48k sample-rate, at 44.1k they stay somewhat in sync.

  • edited January 23

    48k/256 iPad 9th gen here.

    When I try to change the sample rate to 44.1 I get a popup saying that it doesn't support the sample rate or that it's controlled by another application, but Drambo is the only one running. I don't use an interface, I have my headphones plugged into the iPad headphone jack.

    I've experienced this issue with the Drumcomputer plugin before where the flexi sampler recording butchered the first transients. I don't think Audiomodern is the only one, seems to be a bigger issue with Drambo because recording works fine in other apps like AUM.

    It's just that in my workflow I often start in Drambo creating some cool pads, then import the recorded pad pattern into AUMs file player and have it looping while I create the drums around it using the Drumcomputer plugin with multi out. Then I record the drum stems there and reimport them into Drambo where continue arranging the track. That's the best workflow I came up with, but it's of course a bit tainted by the recording glitch in flexi sampler.

Sign In or Register to comment.