MIDI CC Relative (Offset) overdub problem

Hello Forum,

could not find a solution anywhere. I have a Komplete Kontrol and MiniLab MIDI Controller both with Relative Encoders. When I map a control in Drambo everything works as aspected. But when I record in a Loop the control has a red circle around it and gets „glued“ to the initial recorded value. I can not move the value to maximum or minimum.

If this is hard to understand I can make a video.

When I change the controller type to absolute I can record automation in overdub without this behavior but have the parameter jumps.




  • Can you show us the MIDI messages you get from your controller while recording in a loop?

    Do you see any MIDI messages even if you don't touch the knobs?

  • I tried the MIDI I/O Monitor but it only showed Note On/Off messages.

    How can I show you the MIDI Messages?

  • To make sure you actually see all messages, I would use Hexler's Protokol MIDI monitor which also works in slide-over mode on top of Drambo. If you need a MIDI mirror port, running Streambyter standalone in the background would do the job.

    Make sure that control messages are enabled in Protokol.

  • Thanks for the Tipps but I will need some time to test this.

    I made a short video where you can see that without recording everything works as aspected. Which lets me think that this is a Drambo misconfiguring since the MIDI controller does not change when I press record.

  • Did you turn the knob on your controller while recording?

    I have one idea because you wrote that incremental CC don't work as expected:

    If you have a MIDI loop somewhere, this doesn't matter so much with an absolute CC because receiving the same CC twice will just set the same value twice.

    When working with incremental/relative CC though, a MIDI loop will repeat the increments/decrements to the knob movements will be "boosted" in unexpected ways, so to say because the increment or decrement messages will be received multiple times.

  • Yes, maybe this was not clear in my first post. I recorded a MIDI Loop and then I want to overdub the MIDI CC mapped to Cutoff. This only works with absolute MIDI CC and not with Increment MIDI CC.

    The behavior is exactly what you describe with „boosted“ in unexpected ways.

    I just thought because the encoder are touch sensitive that Drambo recognize me touching the knob and then overwrites all MIDI CC for as long as i touch the encoder.

    If this is not the case I will have the use the Absolute Values.

    Thank you.

  • I believe this is the same issue as :

    Your post title seems a bit confusing since it's not an overdub problem but a recording automation issue using a relative encoder (which is weird because it works without recording the automation).

    I have the same result with my akai mpk mini plus and x touch mini, and @rs2000 , you already filed it as a bug :)

    If someone is curious to test it, simply :

    -connect your midi controller to your ipad

    -open a template

    -add any module with a knob

    -assign it to one relative encoder from your controller (make sure it's the right relative CC setting by double tapping the knob while in assign mode)



    -move the physical knob

  • Hello Etienne,

    Yes this looks exactly like my problem.

Sign In or Register to comment.