Impaktor help!!!

Ok, it’s old but I love it! I was wondering if anyone else was having trouble with the loading of Impaktor as an inter-app audio instrument? I’m having no luck and it’s driving me crazy! I tried to email Beepstreet but it won’t allow me to send. The app just says “Launching” but never does!


  • Have you tried the contact page at,

    Or just emailing

    Since iOS 14.5, some older apps need to be refreshed. You could try finding it in iPad Storage. On that page, you can Offload and Reload the app without affecting any data. It might work better after the Reload.

    Also, have you tried starting the app manually before trying to connect using IAA? That sometimes works when a host is unable to launch an app.

  • edited June 2021

    Thanks for your help. I’ve had no luck with the Offload and Reload or starting it manually beforehand. The first email you noted, doesn’t work for me, but appears to work so thank you very much, I appreciate that. Hopefully I’ll hear from them soon. Like I said, I realise it’s an old app but I think it’s a great one. I can’t find anything else quite like it.

  • Another thought: I believe that IAAs require "Local Network" access in order to communicate. Make sure you've granted it under Settings–>Privacy. (This might not work if the app hasn't requested access, and that might be the problem.)

  • just tried it and no luck, it’s not showing in that list. Thanks for all your help - hopefully I’ll get a response from the developers

  • Right. It doesn't show in the list until the app has requested it (via popup). The app may not have been updated to request it. It is a relatively recent feature of iPadOS, but definitely required for IAA.

Sign In or Register to comment.